summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTobias Quathamer <toddy@debian.org>2012-02-17 10:24:27 +0100
committerTobias Quathamer <toddy@debian.org>2012-02-17 10:24:27 +0100
commit9024850f32601de2ed5f9665490912a298f83a1a (patch)
tree147dd72ff429eb2d97f50549e1e12b160b61700a /Makefile.am
downloadiso-codes-9024850f32601de2ed5f9665490912a298f83a1a.tar.gz
Imported Upstream version 3.23upstream/3.23
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..feab9690
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,40 @@
+SUBDIRS = iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3
+
+pkgconfigdir = $(datadir)/pkgconfig
+pkgconfig_DATA = iso-codes.pc
+
+EXTRA_DIST = \
+ LICENSE \
+ rules.make \
+ iso2pot.py \
+ check_valid_utf8.pl
+
+DISTCLEANFILES = $(pkgconfig_DATA)
+
+
+.PHONY: release
+release: update-po check distcheck
+
+.PHONY: update-po
+update-po:
+ for domain in $(SUBDIRS); do \
+ cd $$domain && make update-po && cd ..; \
+ done
+
+.PHONY: sign-release
+sign-release: iso-codes-$(VERSION).tar.bz2
+ rm -f iso-codes-$(VERSION).tar.bz2.sig
+ gpg --detach-sign iso-codes-$(VERSION).tar.bz2
+
+.PHONY: upload
+upload:
+ @if [[ "$(ALIOTH_USERNAME)" == "" ]]; then \
+ echo "Please set your Alioth username. Example command line:"; \
+ echo " ALIOTH_USERNAME=toddy make upload"; \
+ fi
+ @if [[ -f "iso-codes-$(VERSION).tar.bz2" ]] \
+ && [[ -f "iso-codes-$(VERSION).tar.bz2.sig" ]] \
+ && [[ -n "$(ALIOTH_USERNAME)" ]]; then \
+ scp iso-codes-$(VERSION).tar.* \
+ $(ALIOTH_USERNAME)@alioth.debian.org:/var/lib/gforge/chroot/ftproot/pub/pkg-isocodes; \
+ fi