summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDr. Tobias Quathamer <toddy@debian.org>2016-03-02 11:30:14 +0100
committerDr. Tobias Quathamer <toddy@debian.org>2016-03-02 11:30:14 +0100
commit345928f5948a53c974c79418337420e4152c18fa (patch)
tree7d4a343be9d423a25e8d55a08da8f8fe843210dd /configure.ac
parent2e3f15141e55d327c4c086d7fbdcdbb37766d073 (diff)
downloadiso-codes-345928f5948a53c974c79418337420e4152c18fa.tar.gz
Imported Upstream version 3.66upstream/3.66
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac60
1 files changed, 33 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 537dfbfd..056c004c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,20 +1,25 @@
-dnl Copyright (c) 2003, 2004 Christian Persch
-dnl
-dnl This program is free software; you can redistribute it and/or modify it
-dnl under the terms of the GNU General Public License as published by the
-dnl Free Software Foundation; either version 2 of the License, or (at your
-dnl option) any later version.
-dnl
-dnl This program is distributed in the hope that it will be useful, but
-dnl WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl General Public License for more details.
-dnl
-dnl You should have received a copy of the GNU General Public License along
-dnl with this program; if not, write to the Free Software Foundation, Inc.,
-dnl 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
-AC_INIT([iso-codes],[3.65])
+# Process this file with autoconf to produce a configure script.
+#
+# Copyright © 2003-2004 Christian Persch
+# Copyright © 2006-2016 Dr. Tobias Quathamer
+#
+# This file is part of iso-codes.
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 2 of the License, or (at your
+# option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+AC_INIT([iso-codes],[3.66])
AM_INIT_AUTOMAKE([dist-xz no-dist-gzip foreign])
AM_MAINTAINER_MODE
@@ -27,6 +32,7 @@ AC_PROG_MAKE_SET
AC_PATH_PROG([MSGMERGE],[msgmerge])
AC_PATH_PROG([MSGFMT],[msgfmt])
AC_PATH_PROG([MSGFILTER],[msgfilter])
+AC_PATH_PROG([MSGATTRIB],[msgattrib])
AC_PATH_PROG([RECODE_SR_LATIN],[recode-sr-latin])
AC_MSG_CHECKING([if $MSGFMT is GNU msgfmt])
gnu_msgfmt=no
@@ -38,19 +44,19 @@ fi
AC_MSG_RESULT($gnu_msgfmt)
AC_SUBST(MSGFMT_FLAGS)
-DOMAINS="iso_15924 iso_3166 iso_4217 iso_639 iso_3166_2 iso_639_3 iso_639_5"
+DOMAINS="iso_639 iso_639_3 iso_639_5 iso_3166 iso_3166_2 iso_4217 iso_15924"
AC_SUBST([DOMAINS])
AC_CONFIG_FILES([
-Makefile
-iso-codes.pc
-iso_15924/Makefile
-iso_3166/Makefile
-iso_3166_2/Makefile
-iso_4217/Makefile
-iso_639/Makefile
-iso_639_3/Makefile
-iso_639_5/Makefile
+ Makefile
+ iso-codes.pc
+ iso_639/Makefile
+ iso_639_3/Makefile
+ iso_639_5/Makefile
+ iso_3166/Makefile
+ iso_3166_2/Makefile
+ iso_4217/Makefile
+ iso_15924/Makefile
])
AC_OUTPUT