summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJulian Berman <Julian@GrayVines.com>2023-03-15 14:51:09 -0400
committerJulian Berman <Julian@GrayVines.com>2023-03-15 14:51:09 -0400
commit4f0ef528d482968f3648ae8ad535b9dd62f655ad (patch)
treed47c698918fc15c78bdd0b7e5e258d2fab8b40e1 /pyproject.toml
parentdb1e18591333fa72c30fac3b7dfc7ef175612578 (diff)
downloadjsonschema-4f0ef528d482968f3648ae8ad535b9dd62f655ad.tar.gz
Enable ruff's simplify rules too.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 859ff71..784ada3 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -114,7 +114,7 @@ show_error_codes = true
[tool.ruff]
line-length = 79
target-version = "py38"
-select = ["B", "D", "D204", "E", "F", "Q", "UP", "W"]
+select = ["B", "D", "D204", "E", "F", "Q", "SIM", "UP", "W"]
ignore = [
# It's totally OK to call functions for default arguments.
"B008",
@@ -146,10 +146,10 @@ docstring-quotes = "double"
[tool.ruff.per-file-ignores]
"docs/*" = ["D"]
-"jsonschema/cli.py" = ["D", "UP"]
+"jsonschema/cli.py" = ["D", "SIM", "UP"]
"jsonschema/_utils.py" = ["D"]
"jsonschema/benchmarks/*" = ["D"]
-"jsonschema/tests/*" = ["D"]
+"jsonschema/tests/*" = ["D", "SIM"]
[tool.ruff.pyupgrade]
# We support 3.8 + 3.9