summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorHynek Schlawack <hs@ox.cx>2022-08-17 14:43:54 +0200
committerHynek Schlawack <hs@ox.cx>2022-08-17 14:43:54 +0200
commita9b5bb2a7cd02bee23b0d2ea33cdf395854de4df (patch)
treebfbd97e5b5aeea6e26dc4c38a1a60e4c996c44d2 /pyproject.toml
parent0c4aaafe05e7765f7a0b018ebcb0c761747ef9a8 (diff)
downloadjsonschema-a9b5bb2a7cd02bee23b0d2ea33cdf395854de4df.tar.gz
jsonschema deserves a ✨fancy✨ readme
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml25
1 files changed, 22 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 5041a10..7772d77 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["hatchling", "hatch-vcs"]
+requires = ["hatchling", "hatch-vcs", "hatch-fancy-pypi-readme"]
build-backend = "hatchling.build"
[tool.hatch.version]
@@ -8,7 +8,6 @@ source = "vcs"
[project]
name = "jsonschema"
description = "An implementation of JSON Schema validation for Python"
-readme = "README.rst"
requires-python = ">=3.7"
license = {text = "MIT"}
keywords = ["validation", "data validation", "jsonschema", "json"]
@@ -30,7 +29,7 @@ classifiers = [
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
]
-dynamic = ["version"]
+dynamic = ["version", "readme"]
dependencies = [
"attrs>=17.4.0",
@@ -77,6 +76,26 @@ Tidelift = "https://tidelift.com/subscription/pkg/pypi-jsonschema?utm_source=pyp
Changelog = "https://github.com/python-jsonschema/jsonschema/blob/main/CHANGELOG.rst"
Source = "https://github.com/python-jsonschema/jsonschema"
+[tool.hatch.metadata.hooks.fancy-pypi-readme]
+content-type = "text/x-rst"
+
+[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
+path = "README.rst"
+
+[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
+text = """
+
+
+===================
+Release Information
+===================
+
+"""
+
+[[tool.hatch.metadata.hooks.fancy-pypi-readme.fragments]]
+path = "CHANGELOG.rst"
+pattern = "(^v.+?)\nv"
+
[tool.isort]
from_first = true
include_trailing_comma = true