summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJulian Berman <Julian@GrayVines.com>2022-07-29 10:55:46 +0300
committerJulian Berman <Julian@GrayVines.com>2022-07-29 10:55:46 +0300
commitd8c76962859417b1e6fe8c3a59351e49468f7a80 (patch)
treee15feb50748856f6695dbaa990758e5b40eebeac /pyproject.toml
parent438c8fb12546d761c7ce3cba7fe36057c11fe713 (diff)
downloadjsonschema-d8c76962859417b1e6fe8c3a59351e49468f7a80.tar.gz
Replace the vendored twisted.reflect.namedAny with pkgutil.resolve_name.
The stdlib finally has a function for this, though it's 3.9+. (We therefore now also include a backport dependency).
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b08c439..5041a10 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -38,7 +38,9 @@ dependencies = [
"importlib_metadata;python_version<'3.8'",
"typing_extensions;python_version<'3.8'",
+
"importlib_resources>=1.4.0;python_version<'3.9'",
+ "pkgutil_resolve_name>=1.3.10;python_version<'3.9'",
]
[project.optional-dependencies]