summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJulian Berman <Julian@GrayVines.com>2019-06-06 20:10:51 -0400
committerJulian Berman <Julian@GrayVines.com>2019-06-06 20:10:51 -0400
commite95609da897e73a4606682130b12541db7dcbd7d (patch)
treebe43e822b1de86ba47f3a7e9bdfd1a1ff1ae427e /pyproject.toml
parent4e8ba62cf2a0e7c9f2851555184f0d624c5c536b (diff)
downloadjsonschema-e95609da897e73a4606682130b12541db7dcbd7d.tar.gz
Add a pyproject.toml specifying we use setupools.
Closes: #558
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..8fac02e
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,8 @@
+[build-system]
+requires = [
+ # The minimum setuptools version is specific to the PEP 517 backend,
+ # and may be stricter than the version required in `setup.py`
+ "setuptools>=40.6.0",
+ "wheel",
+]
+build-backend = "setuptools.build_meta"