summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@intel.com>2016-08-10 14:20:32 -0300
committerLucas De Marchi <lucas.demarchi@intel.com>2016-08-15 10:26:42 -0300
commit780a4e97e23f0fe961e29ea3b57f5713cfca73a8 (patch)
tree808c65c8964ba2071a644151e9f3e3b6fa041111 /Makefile.am
parenta6421a04e02746af273fed873ff038d81a828f7f (diff)
downloadkmod-780a4e97e23f0fe961e29ea3b57f5713cfca73a8.tar.gz
Add scratchbuf implementation
This should fill the requirements for "we need to loop over a lot of strings that usually are small enough to remain on stack, but we want to protect ourselves against huge strings not fitting in the static buffer we estimated as sufficient"
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 390628a..d4eeb7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,6 +52,7 @@ shared_libshared_la_SOURCES = \
shared/array.h \
shared/hash.c \
shared/hash.h \
+ shared/scratchbuf.c \
shared/strbuf.c \
shared/strbuf.h \
shared/util.c \
@@ -322,6 +323,7 @@ testsuite_libtestsuite_la_LIBADD = -lrt
TESTSUITE = \
testsuite/test-hash \
testsuite/test-array \
+ testsuite/test-scratchbuf \
testsuite/test-strbuf \
testsuite/test-init \
testsuite/test-initstate \
@@ -349,6 +351,9 @@ testsuite_test_hash_CPPFLAGS = $(TESTSUITE_CPPFLAGS)
testsuite_test_array_LDADD = $(TESTSUITE_LDADD)
testsuite_test_array_CPPFLAGS = $(TESTSUITE_CPPFLAGS)
+testsuite_test_scratchbuf_LDADD = $(TESTSUITE_LDADD)
+testsuite_test_scratchbuf_CPPFLAGS = $(TESTSUITE_CPPFLAGS)
+
testsuite_test_strbuf_LDADD = $(TESTSUITE_LDADD)
testsuite_test_strbuf_CPPFLAGS = $(TESTSUITE_CPPFLAGS)