summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@intel.com>2015-02-10 00:45:11 -0200
committerLucas De Marchi <lucas.demarchi@intel.com>2015-02-10 00:45:42 -0200
commite6307200af74d1556466522216e8ae77b7c8b843 (patch)
tree752e3ed562011f36ea380ac1ed1766974c9c1bb5 /configure.ac
parentba52c77e04b0f2d5a9ebee147f4445ac8b1f2b2a (diff)
downloadkmod-e6307200af74d1556466522216e8ae77b7c8b843.tar.gz
build: check for required builtin functions
These builtins are implemented by both gcc and clang since a long time and we don't provide fallback for them. Let the configure phase check for them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3dde5d9..30eea86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,9 @@ AC_CHECK_FUNCS_ONCE(__xstat)
AC_CHECK_FUNCS_ONCE([__secure_getenv secure_getenv])
AC_CHECK_FUNCS_ONCE([finit_module])
+CC_CHECK_FUNC_BUILTIN([__builtin_clz])
+CC_CHECK_FUNC_BUILTIN([__builtin_types_compatible_p])
+
# dietlibc doesn't have st.st_mtim struct member
AC_CHECK_MEMBERS([struct stat.st_mtim], [], [], [#include <sys/stat.h>])