summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarti Maria <info@littlecms.com>2010-02-08 17:20:25 +0100
committerMarti Maria <info@littlecms.com>2010-02-08 17:20:25 +0100
commit3cefc4ee12fe7144a65a205f6645c14ec5be68ce (patch)
tree37c160448e2accb5bbada6f6d4798a90741e4a12 /Makefile.am
downloadlcms2-3cefc4ee12fe7144a65a205f6645c14ec5be68ce.tar.gz
initial commit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..03fe74d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,31 @@
+#
+# Top-Level Makefile for building LittleCMS 2
+#
+
+# Don't require all the GNU mandated files
+AUTOMAKE_OPTIONS = 1.7.2 dist-zip foreign
+
+PACKAGE_NAME = @PACKAGE_NAME@
+PACKAGE_VERSION = @PACKAGE_VERSION@
+
+# Directories containing Makefiles to 'make'
+SUBDIRS = src utils/tificc utils/transicc utils/linkicc utils/jpgicc utils/psicc testbed
+
+# Additional files to distribute
+EXTRA_DIST = AUTHORS COPYING ChangeLog doc Projects include bin lib INSTALL NEWS README.1ST lcms2.pc.in
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = lcms2.pc
+
+# Make sure get rid of VC stuff...
+clean-local:
+ find Projects -name "*.user" | xargs rm -rf
+ find Projects -name "Release" | xargs rm -rf
+ find Projects -name "Debug" | xargs rm -rf
+ find Projects -name "*.aps" | xargs rm -rf
+ find Projects -name "*.suo" | xargs rm -rf
+ find Projects -name "*.log" | xargs rm -rf
+ find Projects -name "*.sdf" | xargs rm -rf
+ find Projects -name "*.opensdf" | xargs rm -rf
+ find Projects -name "*.log" | xargs rm -rf
+ find Projects -name "ipch" | xargs rm -rf \ No newline at end of file