summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Weber <tweber@debian.org>2017-10-21 21:52:45 +0200
committerThomas Weber <tweber@debian.org>2017-10-21 21:52:45 +0200
commit2b29d487d2a2e745dfe457e48c3aa85546022ddf (patch)
treeb9e987a789ccb3ce688f9fa4b0b822f9bfa36677 /configure.ac
parentaaba2cff70d8a114255d1855e223f9912a8c2931 (diff)
downloadlcms2-2b29d487d2a2e745dfe457e48c3aa85546022ddf.tar.gz
Revert "revert "-fvisibility=hidden""
This reverts commit 4ce2fee79c35465b9f182a2e55b7b703a5e60594. Further work on the ax_gcc_func_attribute.m4 will allow this to work on OSX.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 715a855..c59c230 100644
--- a/configure.ac
+++ b/configure.ac
@@ -83,6 +83,15 @@ AM_MAINTAINER_MODE
AC_C_INLINE
AC_SUBST(inline)
+# Check if the C compiler supports the "visibility" function attribute
+# If supported, defines HAVE_FUNC_ATTRIBUTE_VISIBILITY
+AX_GCC_FUNC_ATTRIBUTE(visibility)
+
+# Check if the compiler supports "-fvisibility=hidden" and if yes, add it to CFLAGS
+# This means that symbols that are not marked explicitly for export (CMSAPI)
+# will not be reachable in the shared library.
+AX_APPEND_COMPILE_FLAGS(["-fvisibility=hidden"])
+
# If words are stored with the most significant byte first (like
# Motorola and SPARC CPUs), define `WORDS_BIGENDIAN'.
AC_C_BIGENDIAN