summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2021-03-15 18:58:46 +0100
committerFabrice Fontaine <fontaine.fabrice@gmail.com>2021-03-15 20:25:53 +0100
commitd2f2e9e6f3fada2b887ce1ccbdba36d8eb5a05be (patch)
tree2074a20ada6ddd75d22d4e23a5a7952088be5820 /configure.ac
parentab541149609b20da770f427e9ca72b40230665a4 (diff)
downloadlcms2-d2f2e9e6f3fada2b887ce1ccbdba36d8eb5a05be.tar.gz
configure.ac: fix --without-fastfloat
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b3c8f2b..eec188b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,12 +127,15 @@ AC_ARG_WITH(fastfloat,
AS_HELP_STRING([--with-fastfloat],
[build and install fast_float plugin, use only if GPL 3.0 is acceptable]),
[
- with_fastfloat='yes'
- LIB_PLUGINS="$LIB_PLUGINS -llcms2_fast_float"
+ with_fastfloat=$withval
],
[
with_fastfloat='no'
])
+if test "$with_fastfloat" == "yes"
+then
+ LIB_PLUGINS="$LIB_PLUGINS -llcms2_fast_float"
+fi
#
# Determine POSIX threads settings