summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormm2 <marti.maria@littlecms.com>2020-11-02 22:28:45 +0100
committermm2 <marti.maria@littlecms.com>2020-11-02 22:28:45 +0100
commite32ca1d8f144f0eab3541a0ed59d1863319ca989 (patch)
tree47be2f7d8358be16fea60278975132de395dfa95 /configure.ac
parentca3af953033b67bb7b686db143e586bcc83f74a9 (diff)
downloadlcms2-e32ca1d8f144f0eab3541a0ed59d1863319ca989.tar.gz
hopefully, fix the plugin compilation
use AM_CONDITIONAL
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 17db250..b3c8f2b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,11 +378,10 @@ AC_CONFIG_FILES([utils/linkicc/Makefile])
AC_CONFIG_FILES([utils/jpgicc/Makefile])
AC_CONFIG_FILES([utils/psicc/Makefile])
AC_CONFIG_FILES([testbed/Makefile])
-if [ test "x$with_fastfloat" = "xyes" ]; then
- AC_CONFIG_FILES([plugins/Makefile])
- AC_CONFIG_FILES([plugins/fast_float/Makefile])
- AC_CONFIG_FILES([plugins/fast_float/src/Makefile])
- AC_CONFIG_FILES([plugins/fast_float/include/Makefile])
- AC_CONFIG_FILES([plugins/fast_float/testbed/Makefile])
-fi
+AM_CONDITIONAL([COND_FASTFLOAT], [test "x$with_fastfloat" = "xyes" ])
+AC_CONFIG_FILES([plugins/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/src/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/include/Makefile])
+AC_CONFIG_FILES([plugins/fast_float/testbed/Makefile])
AC_OUTPUT