summaryrefslogtreecommitdiff
path: root/plugins/threaded/testbed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/threaded/testbed/Makefile.am')
-rw-r--r--plugins/threaded/testbed/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/plugins/threaded/testbed/Makefile.am b/plugins/threaded/testbed/Makefile.am
new file mode 100644
index 0000000..8ddd7cd
--- /dev/null
+++ b/plugins/threaded/testbed/Makefile.am
@@ -0,0 +1,23 @@
+#
+# Makefile for building threaded_testbed
+#
+
+# Don't require all the GNU mandated files
+AUTOMAKE_OPTIONS = 1.7 foreign
+
+AM_CPPFLAGS = -I$(builddir)/../include -I$(srcdir)/../include -I$(srcdir)/../src \
+ -I$(top_builddir)/include
+
+check_PROGRAMS = threaded_testbed
+
+threaded_testbed_LDADD = $(builddir)/../src/liblcms2_threaded.la $(LCMS_LIB_DEPLIBS)
+threaded_testbed_LDFLAGS = -static @LDFLAGS@
+threaded_testbed_SOURCES = threaded_testbed.c
+
+EXTRA_DIST = test0.icc test1.icc test2.icc test3.icc test5.icc
+
+check:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ cp $(srcdir)/test?.icc . ; \
+ fi
+ ./threaded_testbed