summaryrefslogtreecommitdiff
path: root/utils/samples/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'utils/samples/meson.build')
-rw-r--r--utils/samples/meson.build33
1 files changed, 33 insertions, 0 deletions
diff --git a/utils/samples/meson.build b/utils/samples/meson.build
new file mode 100644
index 0000000..17ab13f
--- /dev/null
+++ b/utils/samples/meson.build
@@ -0,0 +1,33 @@
+wtpt_srcs = files(
+ 'wtpt.c',
+)
+
+wtpt_exe = executable(
+ 'wtpt',
+ wtpt_srcs,
+ dependencies: [liblcms2_dep, common_dep],
+)
+
+wtpt_man = files(
+ 'wtpt.1',
+)
+
+# install_man(wtpt_man)
+
+examples = {
+ 'roundtrip': files('roundtrip.c'),
+ 'mktiff8': files('mktiff8.c'),
+ # 'vericc': files('vericc.c'),
+ # The following are commented out because they're LCMS 1
+ # 'mkgrayer': files('mkgrayer.c'),
+ # 'mkcmy': files('mkcmy.c'),
+ # 'itufax': files('itufax.c'),
+}
+
+foreach exe, srcs : examples
+ executable(
+ exe,
+ srcs,
+ dependencies: [liblcms2_dep],
+ )
+endforeach