summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVictor Costan <costan@google.com>2020-04-13 23:18:12 +0000
committerVictor Costan <costan@google.com>2020-04-14 01:10:05 +0000
commit201f52201f5dd9701e7a8ceaa0ec4d344e69e022 (patch)
treeb3b2fa7f9f9e3c6a3f744e72b003597e1d956ce1 /CMakeLists.txt
parentba369ddbaffcfe635dd620d1aa68473b56267065 (diff)
downloadleveldb-201f52201f5dd9701e7a8ceaa0ec4d344e69e022.tar.gz
Remove leveldb::port::kLittleEndian.
Clang 10 includes the optimizations described in https://bugs.llvm.org/show_bug.cgi?id=41761. This means that the platform-independent implementations of {Decode,Encode}Fixed{32,64}() compile to one instruction on the most recent Clang and GCC. PiperOrigin-RevId: 306330166
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be41ba4..ae9b0f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,9 +34,6 @@ option(LEVELDB_BUILD_TESTS "Build LevelDB's unit tests" ON)
option(LEVELDB_BUILD_BENCHMARKS "Build LevelDB's benchmarks" ON)
option(LEVELDB_INSTALL "Install LevelDB's header and library" ON)
-include(TestBigEndian)
-test_big_endian(LEVELDB_IS_BIG_ENDIAN)
-
include(CheckIncludeFile)
check_include_file("unistd.h" HAVE_UNISTD_H)