summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Mumford <cmumford@google.com>2019-05-06 15:00:47 -0700
committerChris Mumford <cmumford@google.com>2019-05-06 15:00:48 -0700
commit900f7d37eb3224059dd37afc6614d3158ddaeb8d (patch)
tree588da379e19041688c05eddff0338e5b3d7a45ce /CMakeLists.txt
parenta7528a5d2bd29126b60a277b528ed606b67c1771 (diff)
parent75fceae7003e217e16b04433831da7528ae56881 (diff)
downloadleveldb-900f7d37eb3224059dd37afc6614d3158ddaeb8d.tar.gz
Merge pull request #624 from adam-azarchs:master
PiperOrigin-RevId: 246903086
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4f16f62..1ea33ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,7 @@ include(CheckCXXSymbolExists)
# (-std=c11), but do expose the function in standard C++ mode (-std=c++11).
check_cxx_symbol_exists(fdatasync "unistd.h" HAVE_FDATASYNC)
check_cxx_symbol_exists(F_FULLFSYNC "fcntl.h" HAVE_FULLFSYNC)
+check_cxx_symbol_exists(O_CLOEXEC "fcntl.h" HAVE_O_CLOEXEC)
include(CheckCXXSourceCompiles)