summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorallangj <allangj1618@gmail.com>2016-04-08 09:08:21 -0600
committerAllan Granados <allan.granados-jimenez@hpe.com>2019-05-05 18:13:39 -0600
commitcd1ec032cd276409ba403cab4d0b2548dd26b890 (patch)
tree893eaf106eb9a8cc75486213f6dfbfd92749dd28 /CMakeLists.txt
parent4bd052d7e8b0469b2b87664388e2a99cb212ecdb (diff)
downloadleveldb-cd1ec032cd276409ba403cab4d0b2548dd26b890.tar.gz
Add argument definition for void c functions.
Allow the use c.h on projects with -Wstrict-prototypes Modify CMakelist to include -Wstrict-prototypes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96592d0..4f16f62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,8 @@ check_cxx_symbol_exists(F_FULLFSYNC "fcntl.h" HAVE_FULLFSYNC)
include(CheckCXXSourceCompiles)
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wstrict-prototypes")
+
# Test whether -Wthread-safety is available. See
# https://clang.llvm.org/docs/ThreadSafetyAnalysis.html
# -Werror is necessary because unknown attributes only generate warnings.