summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Capello <davidcapello@gmail.com>2019-10-10 20:34:52 -0300
committerDavid Capello <davidcapello@gmail.com>2020-04-18 15:39:13 -0300
commit2836d83c06af0cc3168889bcc2f71f791726ae36 (patch)
tree645926dbb355f33291b071c9758a7d4ed14f446b /CMakeLists.txt
parentc17709fca64307edc6e1f15b5bb7a648271edadb (diff)
downloadlibarchive-2836d83c06af0cc3168889bcc2f71f791726ae36.tar.gz
Disable error using deprecated functions on macOS 10.15 to calculate MD5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a9f3d19..7782608c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2036,6 +2036,11 @@ IF(MSVC)
ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
ENDIF(MSVC)
+IF(APPLE)
+ # CC_MD5_Init() functions are deprecated on macOS 10.15, but we want to use them
+ ADD_DEFINITIONS(-Wno-deprecated-declarations)
+ENDIF(APPLE)
+
IF(ENABLE_TEST)
ADD_CUSTOM_TARGET(run_all_tests)
ENDIF(ENABLE_TEST)