summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichihiro NAKAJIMA <ggcueroad@gmail.com>2009-01-18 08:00:43 -0500
committerMichihiro NAKAJIMA <ggcueroad@gmail.com>2009-01-18 08:00:43 -0500
commit2ef11b4dcd18fb125e5be0de656ce49e06ea6cdf (patch)
tree712d0634ec3bff2d1d833199142b55fed6a4fbd0 /CMakeLists.txt
parent567f75799ea50206914a7cda08b77dcb84b93bab (diff)
downloadlibarchive-2ef11b4dcd18fb125e5be0de656ce49e06ea6cdf.tar.gz
Eliminate many warnings when link libarchive_test
on Windows. This definition does not affect other platform. SVN-Revision: 439
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e7e068c..abd6e00e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -613,6 +613,8 @@ IF(ENABLE_TEST)
${libarchive_test_SOURCES})
ADD_EXECUTABLE(libarchive_test ${libarchive_test_SOURCES})
TARGET_LINK_LIBRARIES(libarchive_test ${ADDITIONAL_LIBS})
+ SET_PROPERTY(TARGET libarchive_test PROPERTY COMPILE_DEFINITIONS
+ LIBARCHIVE_STATIC)
ADD_TEST(libarchive_test libarchive_test
-r ${CMAKE_CURRENT_SOURCE_DIR}/libarchive/test)
ENDIF(ENABLE_TEST)