summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Kientzle <kientzle@acm.org>2016-09-04 16:15:28 -0700
committerTim Kientzle <kientzle@acm.org>2016-09-04 16:15:28 -0700
commit405ac6fd7a707ebe2eb8ec706a8384a15c2ba0c3 (patch)
treed91487fc131a4082ef97844ef286bb2f505dade7 /CMakeLists.txt
parentf8d2cc0920e5287308a6164b63628c93443dcd25 (diff)
parentd3bea0ab6669cba7144faf440c48d6427df7dee4 (diff)
downloadlibarchive-405ac6fd7a707ebe2eb8ec706a8384a15c2ba0c3.tar.gz
Merge branch 'fix_acls_inside_subdirs' of https://github.com/mmatuska/libarchive into mmatuska-fix_acls_inside_subdirs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7aec17f9..a376fce5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1604,6 +1604,7 @@ IF(ENABLE_ACL)
# test for specific permissions in a permset.) Linux uses the obvious
# name, FreeBSD adds _np to mark it as "non-Posix extension."
# Test for both as a double-check that we really have POSIX-style ACL support.
+ CHECK_FUNCTION_EXISTS(acl_get_fd_np HAVE_ACL_GET_FD_NP)
CHECK_FUNCTION_EXISTS(acl_get_perm HAVE_ACL_GET_PERM)
CHECK_FUNCTION_EXISTS(acl_get_perm_np HAVE_ACL_GET_PERM_NP)
CHECK_FUNCTION_EXISTS(acl_get_link HAVE_ACL_GET_LINK)