summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Torri <vtorri@outlook.fr>2022-09-20 07:07:20 +0200
committerVincent Torri <vtorri@outlook.fr>2022-09-20 07:07:20 +0200
commit6801a72707b9923fad868442f1e4e319464051d8 (patch)
treec2cfad1c6cc8e52cb27097dbbb59d78bc355e2d5 /CMakeLists.txt
parent01a280fbf0794f575eb39d718a558896add18d30 (diff)
downloadlibarchive-6801a72707b9923fad868442f1e4e319464051d8.tar.gz
cmake: update possible values of WINDOWS_VERSION to also support Windows 10
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index df83ed18..d89966e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,7 +243,11 @@ IF(ENABLE_TEST)
ENDIF(ENABLE_TEST)
IF(WIN32)
- IF(WINDOWS_VERSION STREQUAL "WIN8")
+ IF(WINDOWS_VERSION STREQUAL "WIN10")
+ SET(NTDDI_VERSION 0x0A000000)
+ SET(_WIN32_WINNT 0x0A00)
+ SET(WINVER 0x0A00)
+ ELSEIF(WINDOWS_VERSION STREQUAL "WIN8")
SET(NTDDI_VERSION 0x06020000)
SET(_WIN32_WINNT 0x0602)
SET(WINVER 0x0602)
@@ -267,12 +271,12 @@ IF(WIN32)
SET(NTDDI_VERSION 0x05010000)
SET(_WIN32_WINNT 0x0501)
SET(WINVER 0x0501)
- ELSE(WINDOWS_VERSION STREQUAL "WIN8")
+ ELSE(WINDOWS_VERSION STREQUAL "WIN10")
# Default to Windows Server 2003 API if we don't recognize the specifier
SET(NTDDI_VERSION 0x05020000)
SET(_WIN32_WINNT 0x0502)
SET(WINVER 0x0502)
- ENDIF(WINDOWS_VERSION STREQUAL "WIN8")
+ ENDIF(WINDOWS_VERSION STREQUAL "WIN10")
ENDIF(WIN32)
IF(MSVC)