summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim Kientzle <kientzle@gmail.com>2009-03-08 04:42:26 -0400
committerTim Kientzle <kientzle@gmail.com>2009-03-08 04:42:26 -0400
commit75bd264fb7aebef34f309ac951da230f33bb9600 (patch)
treec8c6079a0eacdb82df9b35b3e18e14d9fc01041d /Makefile.am
parent56902948186774bbbbef38fc5b940088549f6c85 (diff)
downloadlibarchive-75bd264fb7aebef34f309ac951da230f33bb9600.tar.gz
Since the most popular XZ decompression library also supports LZMA,
just fold the LZMA handling into the XZ reader. This also eliminates some duplication of bid code. Also, clean up the style a bit to exploit the peek/consume I/O style. SVN-Revision: 747
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b17e6bab..760dae5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -109,7 +109,6 @@ libarchive_la_SOURCES= \
libarchive/archive_read_support_compression_gzip.c \
libarchive/archive_read_support_compression_none.c \
libarchive/archive_read_support_compression_program.c \
- libarchive/archive_read_support_compression_lzma.c \
libarchive/archive_read_support_compression_xz.c \
libarchive/archive_read_support_format_all.c \
libarchive/archive_read_support_format_ar.c \