summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndreas Henriksson <andreas@fatal.se>2009-02-05 12:25:11 -0500
committerAndreas Henriksson <andreas@fatal.se>2009-02-05 12:25:11 -0500
commite2f46586ad891011d6d642c7db00222232ee7df6 (patch)
tree52b100f5481cc0d01f51d5fd89645446e7b80957 /Makefile.am
parent7b30f85b00946ab7844b9a8241033ea8ce3d30f1 (diff)
downloadlibarchive-e2f46586ad891011d6d642c7db00222232ee7df6.tar.gz
Add Joliet Extension support for iso9660.
Joliet extension will currently be preferred (meaning RockRidge will not be spotted if the iso has both, option to ignore Joliet coming soon). This implementation limits the max filename length to 64 characters according to spec, but there are indications about some implementations allowing more so that might need to be bumped. Also includes testcases for joliet and joliet+rr. The joliet+rr testcase is currently disabled as libarchive (currently) can't handle both extensions at the same time. SVN-Revision: 558
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 25452f50..bf914abc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -216,6 +216,8 @@ libarchive_test_SOURCES= \
libarchive/test/test_read_format_gtar_lzma.c \
libarchive/test/test_read_format_gtar_sparse.c \
libarchive/test/test_read_format_iso_gz.c \
+ libarchive/test/test_read_format_isojoliet_bz2.c \
+ libarchive/test/test_read_format_isojolietrr_bz2.c \
libarchive/test/test_read_format_isorr_bz2.c \
libarchive/test/test_read_format_mtree.c \
libarchive/test/test_read_format_pax_bz2.c \
@@ -279,6 +281,8 @@ libarchive_test_EXTRA_DIST=\
libarchive/test/test_read_format_gtar_sparse_1_17_posix01.tar.uu \
libarchive/test/test_read_format_gtar_sparse_1_17_posix10.tar.uu \
libarchive/test/test_read_format_gtar_sparse_1_17_posix10_modified.tar.uu \
+ libarchive/test/test_read_format_isojoliet_bz2.iso.bz2.uu \
+ libarchive/test/test_read_format_isojolietrr_bz2.iso.bz2.uu \
libarchive/test/test_read_format_isorr_bz2.iso.bz2.uu \
libarchive/test/test_read_format_tar_empty_filename.tar.uu \
libarchive/test/test_read_format_zip.zip.uu