summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorgoshhhy <37872995+goshhhy@users.noreply.github.com>2020-05-24 14:17:44 -0900
committerGitHub <noreply@github.com>2020-05-24 14:17:44 -0900
commit4394d8b2b8032594ef7256cc233c0a49ecd78485 (patch)
treee36a7659434bfa6ad49a8184103d2ec887ed90ae /configure.ac
parent48c375370bb5da0509148bb2ee0075b818e2094e (diff)
downloadlibarchive-4394d8b2b8032594ef7256cc233c0a49ecd78485.tar.gz
configure.ac: check if flags are needed for c99
some older and more obscure compilers (e.g. mipspro on irix) default to the strictest standard they know instead of the most permissive. since libarchive uses c99 features in several places throughout, but does not pass appropriate cflags to parse c99 code, it will fail to compile from the configure script on these systems. this change will have autoconf check if any flags are needed for the c compiler to accept c99 code, and add them to cflags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7744365a..41ba5a49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,7 @@ AC_SUBST(PLATFORMCPPFLAGS)
# Checks for programs.
AC_PROG_CC
+AC_PROG_CC_C99
AM_PROG_CC_C_O
AC_USE_SYSTEM_EXTENSIONS
AC_LIBTOOL_WIN32_DLL