summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Matuska <martin@matuska.org>2021-08-21 01:39:31 +0200
committerMartin Matuska <martin@matuska.org>2021-08-21 02:53:33 +0200
commit5e646b890fb3c59ef6f94221ef8ef9ae62a8a9d6 (patch)
treec5d40b1f79737c55f3d6d4b6d2cdb14c835762b5 /configure.ac
parentc6f17a04481f265b4eaca8e3fa586d7ba2461a35 (diff)
downloadlibarchive-5e646b890fb3c59ef6f94221ef8ef9ae62a8a9d6.tar.gz
Fix extracting hardlinks to symlinks
On platforms that support the linkat(2) function we can safely write hardlinks to symlinks as linkat(2) does not follow symlinks by default. Fixes #1044
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2c3838ef..337aa8e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,7 +656,7 @@ AC_CHECK_FUNCS([fstat fstatat fstatfs fstatvfs ftruncate])
AC_CHECK_FUNCS([futimens futimes futimesat])
AC_CHECK_FUNCS([geteuid getpid getgrgid_r getgrnam_r])
AC_CHECK_FUNCS([getpwnam_r getpwuid_r getvfsbyname gmtime_r])
-AC_CHECK_FUNCS([lchflags lchmod lchown link localtime_r lstat lutimes])
+AC_CHECK_FUNCS([lchflags lchmod lchown link linkat localtime_r lstat lutimes])
AC_CHECK_FUNCS([mbrtowc memmove memset])
AC_CHECK_FUNCS([mkdir mkfifo mknod mkstemp])
AC_CHECK_FUNCS([nl_langinfo openat pipe poll posix_spawnp readlink readlinkat])