summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBiswapriyo Nath <nathbappai@gmail.com>2022-04-03 14:24:04 +0530
committerBiswapriyo Nath <nathbappai@gmail.com>2022-04-09 01:33:53 +0530
commit9210f025d0a8938b2e6a7c5d1cd2e8d0eba396be (patch)
tree5f2b56a8db131fbe31bc3a6c87f46aa25b31236a /configure.ac
parent9ad5f077491b9536f01dadca1724385c39cd7613 (diff)
downloadlibarchive-9210f025d0a8938b2e6a7c5d1cd2e8d0eba396be.tar.gz
Revert "Fix check for openssl on Windows"
This reverts commit 045e5c5a4460020e513516a5d1f3087094e67da3 For Windows platform, openssl 1.0.2 and earlier versions have eay64 and eay32 libraries[1]. But from openssl 1.1.0 and above versions have same library name[2] (libcrypto and libssl) like other unix-like platforms. [1]: https://wiki.openssl.org/index.php/Compilation_and_Installation#OpenSSL_1.0.2 [2]: https://wiki.openssl.org/index.php/Compilation_and_Installation#OpenSSL_1.1.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 2c9e1f95..7c6d577e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1209,24 +1209,7 @@ fi
if test "x$with_openssl" != "xno"; then
AC_CHECK_HEADERS([openssl/evp.h])
saved_LIBS=$LIBS
- case "$host_os" in
- *mingw* | *cygwin* | *msys*)
- case "$host_cpu" in
- x86_64)
- AC_CHECK_LIB(eay64,OPENSSL_config)
- if test "x$ac_cv_lib_eay64_main" != "xyes"; then
- AC_CHECK_LIB(eay32,OPENSSL_config)
- fi
- ;;
- *)
- AC_CHECK_LIB(eay32,OPENSSL_config)
- ;;
- esac
- ;;
- *)
- AC_CHECK_LIB(crypto,OPENSSL_config)
- ;;
- esac
+ AC_CHECK_LIB(crypto,OPENSSL_config)
CRYPTO_CHECK(MD5, OPENSSL, md5)
CRYPTO_CHECK(RMD160, OPENSSL, rmd160)
CRYPTO_CHECK(SHA1, OPENSSL, sha1)