summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBiswapriyo Nath <nathbappai@gmail.com>2022-04-13 09:48:44 +0530
committerBiswapriyo Nath <nathbappai@gmail.com>2022-04-13 09:48:44 +0530
commita83f3d327aefe8d628230f326621b014d82f55b4 (patch)
treeedc6ff6433c5c4e6c487c5dc30c9b4fea495dafb /configure.ac
parent042956b1b828d57f142f36ae8f27519c7700bb71 (diff)
downloadlibarchive-a83f3d327aefe8d628230f326621b014d82f55b4.tar.gz
autotools: Fix static linking when openssl is enabled in windows
This adds Requires.private field in pkgconfig file. Using that field, pkgconfig pulls all the private cflags or libs while static linking. OpenSSL static libraries require some windows system libraies. Otherwise static liking fails with libarchive.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f53fae3..b30430d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,6 +378,7 @@ if test "x$with_iconv" != "xno"; then
AC_CHECK_HEADERS([localcharset.h])
am_save_LIBS="$LIBS"
LIBS="${LIBS} ${LIBICONV}"
+ LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }iconv"
AC_CHECK_FUNCS([locale_charset])
LIBS="${am_save_LIBS}"
if test "x$ac_cv_func_locale_charset" != "xyes"; then
@@ -1209,6 +1210,7 @@ fi
if test "x$with_openssl" != "xno"; then
AC_CHECK_HEADERS([openssl/evp.h])
saved_LIBS=$LIBS
+ LIBSREQUIRED="$LIBSREQUIRED${LIBSREQUIRED:+ }libssl libcrypto"
AC_CHECK_LIB(crypto,OPENSSL_config)
CRYPTO_CHECK(MD5, OPENSSL, md5)
CRYPTO_CHECK(RMD160, OPENSSL, rmd160)
@@ -1219,6 +1221,8 @@ if test "x$with_openssl" != "xno"; then
AC_CHECK_FUNCS([PKCS5_PBKDF2_HMAC_SHA1])
fi
+AC_SUBST(LIBSREQUIRED)
+
# Probe libmd AFTER OpenSSL/libcrypto.
# The two are incompatible and OpenSSL is more complete.
AC_CHECK_HEADERS([md5.h ripemd.h sha.h sha256.h sha512.h])