summaryrefslogtreecommitdiff
path: root/cpio/CMakeLists.txt
diff options
context:
space:
mode:
authorMichihiro NAKAJIMA <ggcueroad@gmail.com>2009-03-24 05:04:15 -0400
committerMichihiro NAKAJIMA <ggcueroad@gmail.com>2009-03-24 05:04:15 -0400
commit7dd9d16b204956b2f9ee14144781197a6c2b9740 (patch)
tree688578980cc698f390cabed0a77c07a1f5e6a271 /cpio/CMakeLists.txt
parentfe601609e5ade6a0a87c7a1a9df221fd56f8b067 (diff)
downloadlibarchive-7dd9d16b204956b2f9ee14144781197a6c2b9740.tar.gz
Remove a lot of duplicate functions which simulates POSIX
function for Windows platform. And move the remaining simulate functions to archive_windows.[ch]. It will be easy maintenance and avoid the same named functions having different codes. This change does *not* mean libarchive library has those ones or exports it. All libarchive's executable programs include archive_windows.c for one of its program files. SVN-Revision: 838
Diffstat (limited to 'cpio/CMakeLists.txt')
-rw-r--r--cpio/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpio/CMakeLists.txt b/cpio/CMakeLists.txt
index 4744ba14..f8d39a07 100644
--- a/cpio/CMakeLists.txt
+++ b/cpio/CMakeLists.txt
@@ -18,6 +18,7 @@ IF(ENABLE_CPIO)
IF(WIN32 AND NOT CYGWIN)
LIST(APPEND bsdcpio_SOURCES cpio_windows.c)
LIST(APPEND bsdcpio_SOURCES cpio_windows.h)
+ LIST(APPEND bsdcpio_SOURCES ../libarchive/archive_windows.c)
ENDIF(WIN32 AND NOT CYGWIN)
SET(bsdcpio_MANS bsdcpio.1)