summaryrefslogtreecommitdiff
path: root/libarchive/CMakeLists.txt
diff options
context:
space:
mode:
authorGrzegorz Antoniak <ga@anadoxin.org>2018-12-15 08:38:26 +0100
committerGrzegorz Antoniak <ga@anadoxin.org>2018-12-18 07:17:59 +0100
commit121035c83e18b70d3128e9ac966109ebedb7e516 (patch)
treeceabdeb22ced09c7e9244b280bac14ddb9131676 /libarchive/CMakeLists.txt
parent2a17638861d60ce543373f48bdaa5b5a29e18306 (diff)
downloadlibarchive-121035c83e18b70d3128e9ac966109ebedb7e516.tar.gz
ZIP reader: added support for XZ, LZMA, PPMD8 and BZIP2 decompression
This commit adds some support for extraction of '.zipx' files. Those files are standard ZIP files that can contain files compressed with different set of algorithms that standard '.zip' files use. Support is still missing for Deflate64, JPEG and WavPack algorithms.
Diffstat (limited to 'libarchive/CMakeLists.txt')
-rw-r--r--libarchive/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libarchive/CMakeLists.txt b/libarchive/CMakeLists.txt
index 79719773..8e86aade 100644
--- a/libarchive/CMakeLists.txt
+++ b/libarchive/CMakeLists.txt
@@ -51,6 +51,8 @@ SET(libarchive_SOURCES
archive_platform_acl.h
archive_platform_xattr.h
archive_ppmd_private.h
+ archive_ppmd8.c
+ archive_ppmd8_private.h
archive_ppmd7.c
archive_ppmd7_private.h
archive_private.h