summaryrefslogtreecommitdiff
path: root/libarchive/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-10-21 12:02:43 -0400
committerBrad King <brad.king@kitware.com>2015-10-26 10:20:47 -0400
commit3c445f393bb70b0a551680bd633dbf183a1efb54 (patch)
tree64b078670ccd9ef996740e2f20970e93ab78ffcc /libarchive/CMakeLists.txt
parent5474f3cf6236d8d4f96af61b26d53f3ab60f3be0 (diff)
downloadlibarchive-3c445f393bb70b0a551680bd633dbf183a1efb54.tar.gz
Forward declare __archive_get_date in a dedicated internal header
Avoid repeating the signature declaration in every source that uses it. While at it, constify internal __archive_get_date implementation to keep signatures consistent.
Diffstat (limited to 'libarchive/CMakeLists.txt')
-rw-r--r--libarchive/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libarchive/CMakeLists.txt b/libarchive/CMakeLists.txt
index f427e97d..4cc9a2ca 100644
--- a/libarchive/CMakeLists.txt
+++ b/libarchive/CMakeLists.txt
@@ -34,6 +34,7 @@ SET(libarchive_SOURCES
archive_entry_strmode.c
archive_entry_xattr.c
archive_getdate.c
+ archive_getdate.h
archive_hmac.c
archive_hmac_private.h
archive_match.c