summaryrefslogtreecommitdiff
path: root/libarchive/CMakeLists.txt
diff options
context:
space:
mode:
authorAndres Mejia <amejia004@gmail.com>2012-12-09 13:12:01 -0500
committerAndres Mejia <amejia004@gmail.com>2012-12-09 13:13:42 -0500
commitdb703d251eed99d779c3e99985a93e6905f4963e (patch)
treea7cc0c942a2638d0040d4e1d6557978d00885eec /libarchive/CMakeLists.txt
parent82b5d8dfb3c358df513d2fb89aa6a5b90188b4c2 (diff)
downloadlibarchive-db703d251eed99d779c3e99985a93e6905f4963e.tar.gz
Separate code to set formats/filters into different source files.
This needs close_filters and free_filters to be globally available as global symbols __archive_read_close_filters and __archive_read_free_filters.
Diffstat (limited to 'libarchive/CMakeLists.txt')
-rw-r--r--libarchive/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libarchive/CMakeLists.txt b/libarchive/CMakeLists.txt
index a57244d0..ecb0409b 100644
--- a/libarchive/CMakeLists.txt
+++ b/libarchive/CMakeLists.txt
@@ -45,6 +45,7 @@ SET(libarchive_SOURCES
archive_rb.c
archive_rb.h
archive_read.c
+ archive_read_append_filter.c
archive_read_data_into_fd.c
archive_read_disk_entry_from_file.c
archive_read_disk_posix.c
@@ -56,6 +57,7 @@ SET(libarchive_SOURCES
archive_read_open_filename.c
archive_read_open_memory.c
archive_read_private.h
+ archive_read_set_format.c
archive_read_set_options.c
archive_read_support_filter_all.c
archive_read_support_filter_bzip2.c