summaryrefslogtreecommitdiff
path: root/tar/CMakeLists.txt
diff options
context:
space:
mode:
authorMichihiro NAKAJIMA <ggcueroad@gmail.com>2011-11-15 03:27:08 -0500
committerMichihiro NAKAJIMA <ggcueroad@gmail.com>2011-11-15 03:27:08 -0500
commit576f56e1946b3084b53e160bef5432365a4a92bb (patch)
tree87eeceb3996539ddeeac963f25ae6a9fa4ddab7b /tar/CMakeLists.txt
parentff922b50705f5e5570356267afd21668c6aefab3 (diff)
downloadlibarchive-576f56e1946b3084b53e160bef5432365a4a92bb.tar.gz
I stupidly misunderstood a handling of CMake build options, ENABLE_TAR, ENABLE_TAR_SHARED,
ENABLE_CPIO and ENABLE_CPIO_SHARED, in r3240 and r3713. And that had made bsdtar and bsdcpio disabled or being test failure on Windows platform. - Simplify CMake build options; all platforms have the same default build options. - Back out r3713. SVN-Revision: 3791
Diffstat (limited to 'tar/CMakeLists.txt')
-rw-r--r--tar/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tar/CMakeLists.txt b/tar/CMakeLists.txt
index 546023e5..6682f0ad 100644
--- a/tar/CMakeLists.txt
+++ b/tar/CMakeLists.txt
@@ -3,7 +3,7 @@
# How to build bsdtar
#
############################################
-IF(ENABLE_TAR OR ENABLE_TAR_SHARED)
+IF(ENABLE_TAR)
SET(bsdtar_SOURCES
bsdtar.c
@@ -50,6 +50,6 @@ IF(ENABLE_TAR OR ENABLE_TAR_SHARED)
# Installation rules
INSTALL(TARGETS bsdtar RUNTIME DESTINATION bin)
INSTALL_MAN(${bsdtar_MANS})
-ENDIF(ENABLE_TAR OR ENABLE_TAR_SHARED)
+ENDIF(ENABLE_TAR)
add_subdirectory(test)