summaryrefslogtreecommitdiff
path: root/tar/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Kientzle <kientzle@gmail.com>2010-01-03 16:25:38 -0500
committerTim Kientzle <kientzle@gmail.com>2010-01-03 16:25:38 -0500
commit5cd96832b563045304fe1655afcbc26c02e0840a (patch)
treeff011dc99962f9dcea7f6273227112da177d6ab3 /tar/CMakeLists.txt
parent9242a7a7430f5467d5520196d8128242c884704c (diff)
downloadlibarchive-5cd96832b563045304fe1655afcbc26c02e0840a.tar.gz
Issue 48: Instead of setting RUNTIME_OUTPUT_DIRECTORY separately for
each component, set CMAKE_RUNTIME_OUTPUT_DIRECTORY once at the top and let each component inherit that implicitly. This allows other projects that want to include libarchive to do so a little more simply. SVN-Revision: 1800
Diffstat (limited to 'tar/CMakeLists.txt')
-rw-r--r--tar/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/tar/CMakeLists.txt b/tar/CMakeLists.txt
index d7002233..2ed8161d 100644
--- a/tar/CMakeLists.txt
+++ b/tar/CMakeLists.txt
@@ -45,11 +45,6 @@ IF (ENABLE_TAR)
SET_TARGET_PROPERTIES(bsdtar PROPERTIES COMPILE_DEFINITIONS
LIBARCHIVE_STATIC)
ENDIF(ENABLE_TAR_SHARED)
- # On Windows, DLL must end up in same dir with EXEs
- IF(WIN32 AND NOT CYGWIN)
- SET_TARGET_PROPERTIES(bsdtar PROPERTIES
- RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
- ENDIF(WIN32 AND NOT CYGWIN)
GET_TARGET_PROPERTY(BSDTAR bsdtar LOCATION)
# Installation rules