summaryrefslogtreecommitdiff
path: root/tar/CMakeLists.txt
diff options
context:
space:
mode:
authorMichihiro NAKAJIMA <ggcueroad@gmail.com>2009-03-24 05:04:15 -0400
committerMichihiro NAKAJIMA <ggcueroad@gmail.com>2009-03-24 05:04:15 -0400
commit7dd9d16b204956b2f9ee14144781197a6c2b9740 (patch)
tree688578980cc698f390cabed0a77c07a1f5e6a271 /tar/CMakeLists.txt
parentfe601609e5ade6a0a87c7a1a9df221fd56f8b067 (diff)
downloadlibarchive-7dd9d16b204956b2f9ee14144781197a6c2b9740.tar.gz
Remove a lot of duplicate functions which simulates POSIX
function for Windows platform. And move the remaining simulate functions to archive_windows.[ch]. It will be easy maintenance and avoid the same named functions having different codes. This change does *not* mean libarchive library has those ones or exports it. All libarchive's executable programs include archive_windows.c for one of its program files. SVN-Revision: 838
Diffstat (limited to 'tar/CMakeLists.txt')
-rw-r--r--tar/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tar/CMakeLists.txt b/tar/CMakeLists.txt
index 2d60f79a..5aee9187 100644
--- a/tar/CMakeLists.txt
+++ b/tar/CMakeLists.txt
@@ -22,6 +22,7 @@ IF (ENABLE_TAR)
IF(WIN32 AND NOT CYGWIN)
LIST(APPEND bsdtar_SOURCES bsdtar_windows.c)
LIST(APPEND bsdtar_SOURCES bsdtar_windows.h)
+ LIST(APPEND bsdtar_SOURCES ../libarchive/archive_windows.c)
ENDIF(WIN32 AND NOT CYGWIN)
SET(bsdtar_MANS bsdtar.1)