summaryrefslogtreecommitdiff
path: root/tar/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Kientzle <kientzle@gmail.com>2009-11-16 01:26:09 -0500
committerTim Kientzle <kientzle@gmail.com>2009-11-16 01:26:09 -0500
commit99510e132890526d71fb065f09c2bd9c3658b179 (patch)
treed7dd61b3520312ce4557f601e45f9aa0bc6a6c77 /tar/CMakeLists.txt
parentd958c04318cbe19925f4498f59d65f8e77a2e9dc (diff)
downloadlibarchive-99510e132890526d71fb065f09c2bd9c3658b179.tar.gz
On Windows, building a client against a static libarchive
requires LIBARCHIVE_STATIC be defined. SVN-Revision: 1653
Diffstat (limited to 'tar/CMakeLists.txt')
-rw-r--r--tar/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tar/CMakeLists.txt b/tar/CMakeLists.txt
index f6a0d0ec..d7002233 100644
--- a/tar/CMakeLists.txt
+++ b/tar/CMakeLists.txt
@@ -42,6 +42,8 @@ IF (ENABLE_TAR)
TARGET_LINK_LIBRARIES(bsdtar archive ${ADDITIONAL_LIBS})
ELSE(ENABLE_TAR_SHARED)
TARGET_LINK_LIBRARIES(bsdtar archive_static ${ADDITIONAL_LIBS})
+ SET_TARGET_PROPERTIES(bsdtar PROPERTIES COMPILE_DEFINITIONS
+ LIBARCHIVE_STATIC)
ENDIF(ENABLE_TAR_SHARED)
# On Windows, DLL must end up in same dir with EXEs
IF(WIN32 AND NOT CYGWIN)