summaryrefslogtreecommitdiff
path: root/cat/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'cat/test/CMakeLists.txt')
-rw-r--r--cat/test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/cat/test/CMakeLists.txt b/cat/test/CMakeLists.txt
index 9dbf4b79..7f1ce5e7 100644
--- a/cat/test/CMakeLists.txt
+++ b/cat/test/CMakeLists.txt
@@ -6,8 +6,7 @@
IF(ENABLE_CAT AND ENABLE_TEST)
SET(bsdcat_test_SOURCES
../../test_utils/test_utils.c
- ../../test_utils/lib/version.c
- main.c
+ ../../test_utils/test_main.c
test.h
test_0.c
test_empty_gz.c
@@ -55,6 +54,7 @@ IF(ENABLE_CAT AND ENABLE_TEST)
INCLUDE(${CMAKE_CURRENT_BINARY_DIR}/list.h)
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
INCLUDE_DIRECTORIES(${PROJECT_SOURCE_DIR}/test_utils)
+ INCLUDE_DIRECTORIES(${PROJECT_SOURCE_DIR}/cat/test)
# Experimental new test handling
ADD_CUSTOM_TARGET(run_bsdcat_test