summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2011-12-01 22:53:03 +0100
committerWerner Koch <wk@gnupg.org>2011-12-01 22:53:03 +0100
commit165a57d29d2ac84159aa48b171b6098c629bc798 (patch)
treeab27496fa66267a528333e2bb8f99077d57b0601 /Makefile.am
parent2e037baefdc40da6961721ad56fc7c38d4e492a8 (diff)
downloadlibassuan-165a57d29d2ac84159aa48b171b6098c629bc798.tar.gz
Generate the ChangeLog from commit logs.
* build-aux/gitlog-to-changelog: New script. Taken from gnulib. * build-aux/git-log-fix: New file. * build-aux/git-log-footer: New file. * doc/HACKING: New file. * ChangeLog: New file. * Makefile.am (EXTRA_DIST): Add new files. (gen-ChangeLog): New. (dist-hook): Run gen-ChangeLog. * autogen.sh: Install commit-msg hook for git. Rename all ChangeLog files to ChangeLog-2011.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 55040e7..e7eeee5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,14 +21,32 @@
ACLOCAL_AMFLAGS = -I m4
AUTOMAKE_OPTIONS = dist-bzip2 no-dist-gzip
-EXTRA_DIST = config.rpath autogen.sh README.GIT
+EXTRA_DIST = config.rpath autogen.sh README.GIT \
+ ChangeLog-2011 doc/ChangeLog-2011 src/ChangeLog-2011 \
+ tests/ChangeLog-2011 contrib/ChangeLog-2011 \
+ build-aux/gitlog-to-changelog build-aux/git-log-footer \
+ build-aux/git-log-fix
SUBDIRS = m4 src doc tests
-dist-hook:
+dist-hook: gen-ChangeLog
echo "$(VERSION)" > $(distdir)/VERSION
+gen_start_date = 2011-12-01T00:00:00
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ if test -d $(top_srcdir)/.git; then \
+ (cd $(top_srcdir) && \
+ ./build-aux/gitlog-to-changelog \
+ --amend=build-aux/git-log-fix \
+ --since=$(gen_start_date) ) > $(distdir)/cl-t; \
+ cat $(top_srcdir)/build-aux/git-log-footer >> $(distdir)/cl-t;\
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+
stowinstall:
$(MAKE) $(AM_MAKEFLAGS) install prefix=/usr/local/stow/libassuan