summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorWerner Koch <wk@gnupg.org>2010-02-24 15:50:55 +0000
committerWerner Koch <wk@gnupg.org>2010-02-24 15:50:55 +0000
commitd20a4d4c79d4f12021383a7aeb5c34a861d858a4 (patch)
treeff2439480e53487d070a20b22faa2fc717b8af63 /src/Makefile.am
parent09633587a0f0301cfef5a745e58c47afb92fce99 (diff)
downloadlibassuan-d20a4d4c79d4f12021383a7aeb5c34a861d858a4.tar.gz
A couple of changes to eventually fully support W32ce.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5895bc5..6403e79 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,6 +25,10 @@ bin_SCRIPTS = libassuan-config
m4datadir = $(datadir)/aclocal
m4data_DATA = libassuan.m4
lib_LTLIBRARIES = libassuan.la
+if HAVE_W32CE_SYSTEM
+lib_LTLIBRARIES += libgpgcedev.la
+bin_PROGRAMS = gpgcemgr
+endif
include_HEADERS = assuan.h
if HAVE_LD_VERSION_SCRIPT
@@ -97,3 +101,12 @@ libassuan_la_LDFLAGS = $(libassuan_res_ldflag) $(no_undefined) \
libassuan_la_DEPENDENCIES = @LTLIBOBJS@ \
$(srcdir)/libassuan.vers $(libassuan_deps)
libassuan_la_LIBADD = @LTLIBOBJS@ @NETLIBS@ @GPG_ERROR_LIBS@
+
+if HAVE_W32CE_SYSTEM
+libgpgcedev_la_SOURCES = gpgcedev.c
+libgpgcedev_la_CPPFLAGS = $(AM_CPPFLAGS)
+libgpgcedev_la_LDFLAGS = $(no_undefined) -export-symbols $(srcdir)/gpgcedev.def
+libgpgcedev_la_DEPENDENCIES = gpgcedev.def
+gpgcemgr_SOURCES = gpgcemgr.c
+gpgcemgr_CPPFLAGS = $(AM_CPPFLAGS)
+endif