summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNIIBE Yutaka <gniibe@fsij.org>2022-11-08 14:37:35 +0900
committerNIIBE Yutaka <gniibe@fsij.org>2022-11-08 14:37:35 +0900
commit8962c1e774e716cde1a7afeaca86558e48960ab1 (patch)
tree924ad77d8f82aefea74efce927cf04c6f5b6b980 /tests/Makefile.am
parent3297e453aa0e371e14fd26e53f4a6f84e20c21d3 (diff)
downloadlibassuan-8962c1e774e716cde1a7afeaca86558e48960ab1.tar.gz
tests: Add fdpassing-socket.sh script.
* tests/Makefile.am (TESTS_ENVIRONMENT): Export EXEEXT. (test_programs): New. Run pipeconnect for Windows, too. (check_SCRIPTS): New. (TESTS): Now, it's test_programs and check_SCRIPTS. (noinst_PROGRAMS): Not including check_SCRIPTS. (tests/fdpassing-socket.sh): New, to test socket connection. * tests/fdpassing.c: Include socket connection test. * tests/pipeconnect.c: Fix for Windows. -- Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 317c66d..fba3b8e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,30 +18,34 @@
## Process this file with automake to produce Makefile.in
-TESTS_ENVIRONMENT =
+TESTS_ENVIRONMENT = EXEEXT=$(EXEEXT); export EXEEXT;
EXTRA_DIST = motd
BUILT_SOURCES =
CLEANFILES =
-TESTS = version
+test_programs = version
+test_programs += pipeconnect
if HAVE_W32_SYSTEM
-TESTS += fdpassing
+test_programs += fdpassing
+check_SCRIPTS = fdpassing-socket.sh
testtools =
else
-TESTS += pipeconnect
testtools = socks5
endif
if USE_DESCRIPTOR_PASSING
-TESTS += fdpassing
+test_programs += fdpassing
+check_SCRIPTS = fdpassing-socket.sh
endif
+TESTS = $(test_programs) $(check_SCRIPTS)
+
AM_CFLAGS = $(GPG_ERROR_CFLAGS)
AM_LDFLAGS = -no-install
noinst_HEADERS = common.h
-noinst_PROGRAMS = $(TESTS) $(w32cetools) $(testtools)
+noinst_PROGRAMS = $(test_programs) $(w32cetools) $(testtools)
LDADD = ../src/libassuan.la $(GPG_ERROR_LIBS) @LDADD_FOR_TESTS_KLUDGE@