summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2017-02-18 09:21:58 +0300
committerIvan Maidanski <ivmai@mail.ru>2017-02-18 09:21:58 +0300
commit3b7e732d7206076a96c15396252bad56cd0cda0f (patch)
treed98ff52fcca03cd33fd7adc6b6e929b13f83621d /configure.ac
parent90bdd4f4fa123affdd1ef6cd472d3ee7c1d330f0 (diff)
downloadlibatomic_ops-3b7e732d7206076a96c15396252bad56cd0cda0f.tar.gz
Add Makefile target (check-nolink) to compile all source without linking
Note: it is assumed --enable-shared is not passed to configure. * Makefile.am (check-nolink-local): New Makefile phony target (just redirects to "all"). * configure.ac: Define check-nolink by AM_EXTRA_RECURSIVE_TARGETS. * tests/Makefile.am (TEST_OBJS): New variable (with a list of the test .o files). * tests/Makefile.am (check-nolink-local): New Makefile phony target (forces all tests to be compiled but not linked).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9087c59..8182af3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,7 @@ AC_CANONICAL_TARGET([])
AC_CONFIG_SRCDIR(src/atomic_ops.c)
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([foreign dist-bzip2 nostdinc])
+AM_EXTRA_RECURSIVE_TARGETS([check-nolink])
AM_MAINTAINER_MODE
AC_CONFIG_HEADERS([src/config.h])