summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2011-12-20 16:34:34 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2011-12-20 16:34:34 +0800
commit642ac3f675176ee6c2e124eac86dd85b1b1816e0 (patch)
tree019848a717db0cb17b6e90e689ebbee77fabbfee /Makefile.am
parent6637c802c0a4c685a4e1866c9f7b033c2dd78979 (diff)
downloadlibcroco-642ac3f675176ee6c2e124eac86dd85b1b1816e0.tar.gz
Bug 666248: Visual C++ compilation support
This enables libcroco to be compiled with Visual C++ 2008/2010, along with its test programs. A libcroco.symbols is included to export the symbols from the DLL that is built in the process, and the projects for the main libcroco DLL is done in a way where their source file listings are filled in during "make dist" as they could be changed from time to time so to simplify maintenanace work. Versioning stuff are also done via autotools as far as possible also. The .sln files have no simple way to include the LGPL 2.1+ terms without causing trouble, so the text for them is included as follows, for references. ------ This file is part of The Croco Library This program is free software; you can redistribute it and/or modify it under the terms of version 2.1 of the GNU Lesser General Public License as published by the Free Software Foundation. This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details. You should have received a copy of the GNU Lesser General Public License along with this program; if not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA Author: Fan, Chun-wei See COPYRIGHTS file for copyright information. ------
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0bbd5b5..c1bf592 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,6 @@
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
-SUBDIRS = src csslint docs
-SUBDIRS += tests
+SUBDIRS = src csslint docs tests build
PKG_CONFIG_FILE_UNINSTALLED=libcroco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-uninstalled.pc
PKG_CONFIG_FILE=libcroco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@.pc
@@ -20,7 +19,7 @@ bin_SCRIPTS=$(CROCO_CONFIG_FILE)
EXTRA_DIST= croco-config.in $(PKG_CONFIG_FILE) TODO Doxyfile \
HACKING COPYING.LIB COPYING libcroco.spec libcroco-zip.in \
-autogen.sh libcroco.doap
+autogen.sh libcroco.doap config.h.win32.in config.h.win32
all-local: $(PKG_CONFIG_FILE_UNINSTALLED) $(PKG_CONFIG_FILE) \
$(CROCO_CONFIG_FILE_UNINSTALLED) $(CROCO_CONFIG_FILE)