summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCEST 2005 Dodji Seketeli <dodji@seketeli.org>2005-05-10 19:48:58 +0000
committerDodji Seketeli <dodji@src.gnome.org>2005-05-10 19:48:58 +0000
commit87e540b6a27f7fcca8b450bb44a8b197eeffb464 (patch)
tree99d68d410ff91b556e58c73b6c5cd262fc7959a6 /Makefile.am
parent3e0fb4e6acd9b29303384da9242b08c70e4d9add (diff)
downloadlibcroco-87e540b6a27f7fcca8b450bb44a8b197eeffb464.tar.gz
applied the following patches:
Tue May 10 21:49:05 CEST 2005 Dodji Seketeli <dodji@seketeli.org> applied the following patches: dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-29 2004-06-09 00:09:41 GMT updated NEWS file for 0.6.0 [Dodji Seketeli] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-30 2004-09-20 16:13:02 GMT fixed a nasty memory management bug [Dodji Seketeli] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-31 2005-02-10 21:41:04 GMT rm test output upon 'make clean' [Peter Moulder] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-32 2005-02-13 13:14:16 GMT make 'all' target a prerequisite of the 'test' target [Peter Moulder] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-33 2005-02-13 19:24:25 GMT allow building/testing in a directory different from srcdir [Peter Moulder/Dodji Seketeli] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-34 2005-02-13 19:42:48 GMT added better api documentation [Peter Moulder] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-35 2005-05-05 16:38:07 GMT initial port to gtk-doc, switch to automake 1.7 [Sven Herzberg, Dodji Seketeli] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-36 2005-05-05 16:51:38 GMT more gtk-doc stuffs [Dodji Seketeli] dodji@gnome.org--xml-style-2004/libcroco--mainline--0.6--patch-37 2005-05-06 14:20:20 GMT typos and c++ compilation fixes [Peter Moulder]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b93330d..de357e2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,11 @@ $(CROCO_CONFIG_FILE_UNINSTALLED) $(CROCO_CONFIG_FILE)
%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config-uninstalled: %-config
cp $< $@
+clean-local: cleantest
+
+cleantest:
+ if test -x $(top_srcdir)/tests/testctl ; then $(top_srcdir)/tests/testctl cleanup ; fi
+
cleantar:
@(rm -f libcroco*.tar.gz)
@(rm -rf $(top_srcdir)/rpmbuildroot)
@@ -42,7 +47,7 @@ cleantar:
rpm: cleantar
@(mkdir -p $(top_srcdir)/rpmbuildroot ; $(MAKE) dist && rpmbuild -ta --buildroot $(top_srcdir)/rpmbuildroot $(distdir).tar.gz)
-test:
+test: all
if test -x $(top_srcdir)/tests/testctl ; then $(top_srcdir)/tests/testctl cleanup ; $(top_srcdir)/tests/testctl run ; fi
apidoc: