summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2011-12-06 01:35:51 +0100
committerChristian Persch <chpe@gnome.org>2011-12-06 01:36:00 +0100
commitaca276a7c1489897523b8d0df07d425a7dab319c (patch)
tree2e229063c81e9671dc3a0a149bac03e83af1b9d5 /Makefile.am
parentc7197cad42d6269739f379025c2bec9e474c8027 (diff)
downloadlibcroco-aca276a7c1489897523b8d0df07d425a7dab319c.tar.gz
Autogenerate ChangeLog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d679710..0bbd5b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,3 +58,14 @@ test: all
apidoc:
if ! test -d docs/apis ; then mkdir -p docs/apis ; fi ;
doxygen Doxyfile
+
+ChangeLog:
+ $(AM_V_GEN) if test -f $(top_srcdir)/.git/HEAD; then \
+ git log --stat > $@; \
+ fi
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+
+