summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDodji Seketeli <dodji@gnome.org>2004-06-08 22:57:27 +0000
committerDodji Seketeli <dodji@src.gnome.org>2004-06-08 22:57:27 +0000
commitada41f72df45d6f44270d54bc5da6ccb79570ceb (patch)
tree7b5e274f5f0ddb2ae13ef1e980debc30035b1b0c /Makefile.am
parentf543f25b62892e6eef5e0a733941a1e3480e02e2 (diff)
downloadlibcroco-ada41f72df45d6f44270d54bc5da6ccb79570ceb.tar.gz
synchronize with libcroco--mainline--0.6--patch-28.tla-cvs-synch-06-09-2004-0
2004-06-09 Dodji Seketeli <dodji@gnome.org> synchronize with libcroco--mainline--0.6--patch-28.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 28 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 5974bf3..b93330d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,17 +1,39 @@
SUBDIRS = src csslint docs
SUBDIRS += tests
+PKG_CONFIG_FILE_UNINSTALLED=libcroco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-uninstalled.pc
+PKG_CONFIG_FILE=libcroco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@.pc
+
pkgconfigdir=$(libdir)/pkgconfig
-pkgconfig_DATA=libcroco.pc
+pkgconfig_DATA=$(PKG_CONFIG_FILE)
+
+INCLUDE_DIR_NAME=@PACKAGE@-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@
+extraincludedir=$(includedir)/$INCLUDE_DIR_NAME
+
+CROCO_CONFIG_FILE_UNINSTALLED=croco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config-uninstalled
+CROCO_CONFIG_FILE=croco-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config
+bin_SCRIPTS=$(CROCO_CONFIG_FILE)
+
+#man_MANS = croco-config.1
+
+EXTRA_DIST= croco-config.in $(PKG_CONFIG_FILE) TODO Doxyfile \
+HACKING COPYING.LIB COPYING libcroco.spec
+
+all-local: $(PKG_CONFIG_FILE_UNINSTALLED) $(PKG_CONFIG_FILE) \
+$(CROCO_CONFIG_FILE_UNINSTALLED) $(CROCO_CONFIG_FILE)
+
-extraincludedir=$(includedir)/@PACKAGE@
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@.pc: %.pc
+ cp $< $@
-bin_SCRIPTS=croco-config
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-uninstalled.pc: %.pc
+ cp $< $@
-man_MANS = croco-config.1
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config: %-config
+ cp $< $@
-EXTRA_DIST= croco-config.in libcroco.pc libcroco.spec TODO Doxyfile \
-HACKING COPYING.LIB COPYING libcroco.spec $(man_MANS)
+%-@LIBCROCO_MAJOR_VERSION@.@LIBCROCO_MINOR_VERSION@-config-uninstalled: %-config
+ cp $< $@
cleantar:
@(rm -f libcroco*.tar.gz)