summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 14:31:27 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 14:31:27 +0800
commitabe78893ecbfe1308b7af95a48da6b0321e04f45 (patch)
tree8b222f36de35b1a60fe44581c488fc7453942888 /configure.ac
parent6c9dfc4b7b9d564058398cf30ac41210427c395a (diff)
downloadlibcroco-abe78893ecbfe1308b7af95a48da6b0321e04f45.tar.gz
Visual Studio builds: Support Visual Studio 2017
This updates the autotools scripts so that we can support Visual Studio 2017 by copying the 2010 projects and update items in there as needed. Note that the format of the toolset version string changed for Visual Studio 2017, so allow a custom toolset version string to be passed in and used, otherwise the platform toolset string is generated as before. Note also that Visual Studio 2017 aims to be compatible with 2015 on the CRT level, so one should be able to use 2017-built binaries with 2015-built binaries without problems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82d27b6..eaf5171 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,13 @@ fi
AC_SUBST([BSYMBOLIC_LDFLAG])
+##############################################
+# Check whether MSVC toolset is explicitly set
+##############################################
+
+AM_CONDITIONAL(MSVC_BASE_NO_TOOLSET_SET, [test x$MSVC_BASE_TOOLSET = x])
+AM_CONDITIONAL(MSVC_NO_TOOLSET_SET, [test x$MSVC_TOOLSET = x])
+
###################
# Compiler warnings
###################
@@ -155,6 +162,7 @@ build/win32/vs10/croco-version-paths.props
build/win32/vs11/Makefile
build/win32/vs12/Makefile
build/win32/vs14/Makefile
+build/win32/vs15/Makefile
docs/Makefile
docs/examples/Makefile
docs/reference/Makefile