summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDodji Seketeli <dodji@src.gnome.org>2003-03-29 15:05:36 +0000
committerDodji Seketeli <dodji@src.gnome.org>2003-03-29 15:05:36 +0000
commit0d5d4e57a3b091909b11a8a5a8fbb85236ac94c2 (patch)
tree6032828c163c19ba79035228545b8a310602c75b /src/Makefile.am
parentdf526da09c8a5faf05101e438b84d5061cb4a091 (diff)
downloadlibcroco-0d5d4e57a3b091909b11a8a5a8fbb85236ac94c2.tar.gz
more code on the layout/cascade front.
some fixes/improvements on the build system front. Dodji.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am60
1 files changed, 35 insertions, 25 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d61592b..d066e42 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,31 +4,41 @@ crocoincdir=$(includedir)/@PACKAGE@
crocoinc_HEADERS= *.h
-libcroco_la_SOURCES= \
- cr-utils.c \
- cr-input.c \
- cr-enc-handler.c \
- cr-num.c \
- cr-rgb.c \
- cr-token.c \
- cr-tknzr.c \
- cr-term.c \
- cr-attr-sel.c \
- cr-pseudo.c \
- cr-additional-sel.c \
- cr-simple-sel.c \
- cr-selector.c \
- cr-doc-handler.c \
- cr-parser.c \
- cr-declaration.c \
- cr-statement.c \
- cr-stylesheet.c \
- cr-om-parser.c \
- cr-sel-eng.c \
- cr-style.c \
- cr-box.c \
- cr-lay-eng.c \
- *.h
+#the core parser files
+SRCS=\
+cr-utils.c \
+cr-input.c \
+cr-enc-handler.c \
+cr-num.c \
+cr-rgb.c \
+cr-token.c \
+cr-tknzr.c \
+cr-term.c \
+cr-attr-sel.c \
+cr-pseudo.c \
+cr-additional-sel.c \
+cr-simple-sel.c \
+cr-selector.c \
+cr-doc-handler.c \
+cr-parser.c \
+cr-declaration.c \
+cr-statement.c \
+cr-stylesheet.c \
+cr-cascade.c \
+cr-om-parser.c \
+*.h
+
+#the selection engine files
+if HAVE_SELENG
+SELENG_SRCS= cr-style.c cr-sel-eng.c
+endif
+
+#the layout engine files
+if HAVE_LAYENG
+LAYENG_SRCS= cr-box.c cr-lay-eng.c
+endif
+
+libcroco_la_SOURCES= $(SRCS) $(SELENG_SRCS) $(LAYENG_SRCS)
INCLUDES=-I$(top_srcdir) -I$(top_srcdir)/intl `pkg-config --cflags glib-2.0` `pkg-config --cflags libxml-2.0` @LIBXML2_CFLAGS@
libcroco_la_LDFLAGS=-version-info @LIBCROCO_VERSION_INFO@ @LIBXML2_LIBS@