summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDodji Seketeli <dodji@src.gnome.org>2003-04-12 16:50:32 +0000
committerDodji Seketeli <dodji@src.gnome.org>2003-04-12 16:50:32 +0000
commit17114030e0e37f93682c903dd818da1f0e2e6f6b (patch)
treef52286082af39c649dfbc86015ab080ac2a55abd /src/Makefile.am
parent4f5560ef67d35121d1087aee9b5e34dece012d8a (diff)
downloadlibcroco-17114030e0e37f93682c903dd818da1f0e2e6f6b.tar.gz
big tree layout cleanup.
Dodji.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am44
1 files changed, 3 insertions, 41 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d066e42..4d4dd60 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,44 +1,6 @@
-lib_LTLIBRARIES=libcroco.la
+SUBDIRS=parser seleng layeng
crocoincdir=$(includedir)/@PACKAGE@
+crocoinc_HEADERS= $(top_srcdir)/src/libcroco.h \
+$(top_srcdir)/libcroco-config.h
-crocoinc_HEADERS= *.h
-
-#the core parser files
-SRCS=\
-cr-utils.c \
-cr-input.c \
-cr-enc-handler.c \
-cr-num.c \
-cr-rgb.c \
-cr-token.c \
-cr-tknzr.c \
-cr-term.c \
-cr-attr-sel.c \
-cr-pseudo.c \
-cr-additional-sel.c \
-cr-simple-sel.c \
-cr-selector.c \
-cr-doc-handler.c \
-cr-parser.c \
-cr-declaration.c \
-cr-statement.c \
-cr-stylesheet.c \
-cr-cascade.c \
-cr-om-parser.c \
-*.h
-
-#the selection engine files
-if HAVE_SELENG
-SELENG_SRCS= cr-style.c cr-sel-eng.c
-endif
-
-#the layout engine files
-if HAVE_LAYENG
-LAYENG_SRCS= cr-box.c cr-lay-eng.c
-endif
-
-libcroco_la_SOURCES= $(SRCS) $(SELENG_SRCS) $(LAYENG_SRCS)
-
-INCLUDES=-I$(top_srcdir) -I$(top_srcdir)/intl `pkg-config --cflags glib-2.0` `pkg-config --cflags libxml-2.0` @LIBXML2_CFLAGS@
-libcroco_la_LDFLAGS=-version-info @LIBCROCO_VERSION_INFO@ @LIBXML2_LIBS@