summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-03-28 10:06:29 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-03-28 10:06:29 +0100
commit0dfe8403dd5d84e7fc4a444e6cc471e715bd8544 (patch)
treee6b6a602954ddc890b53e8075b811c7d0a7f41a4 /meson.build
parent9e7af6e1f568341586f6012a47199c641fb16567 (diff)
downloadlibepoxy-0dfe8403dd5d84e7fc4a444e6cc471e715bd8544.tar.gz
Remove workarounds for older Meson versions
Removing the files() statement allows us to not use source_root(), which breaks using libepoxy as a sub-project. Using the python3 module is better for Windows portability.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 0d75409..ae0cc88 100644
--- a/meson.build
+++ b/meson.build
@@ -223,17 +223,13 @@ configure_file(input: 'epoxy.pc.in',
install_dir: join_paths(epoxy_libdir, 'pkgconfig'))
# Python
-# XXX: Depend on 0.37.1 for:
-# python = import('python3').find_python()
-python = find_program('python3', required: false)
+python = import('python3').find_python()
if not python.found()
python = find_program('python', required: true)
endif
# Generates the dispatch tables
-# XXX: Depend on 0.38.1 for:
-# gen_dispatch_py = files('src/gen_dispatch.py')
-gen_dispatch_py = join_paths(meson.source_root(), 'src/gen_dispatch.py')
+gen_dispatch_py = files('src/gen_dispatch.py')
gl_registry = files('registry/gl.xml')
egl_registry = files('registry/egl.xml')