summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-02 17:01:54 +0000
committerRoss Burton <ross.burton@intel.com>2018-03-12 12:02:08 +0000
commit1267f82021d58a447f5614ceef20509bea47bca3 (patch)
treea6d01bbb2ac7d28d98b7b4339f886dd2219b1aa4 /meson.build
parenta35192b07cabc373e56eec6de2b9bd4fdd7bdee8 (diff)
downloadlibepoxy-1267f82021d58a447f5614ceef20509bea47bca3.tar.gz
meson: generalise build_apple to has_dlvsym
build_apple was introduced in 756dca as a proxy for the fact that Apple's libc doesn't have dlvsym(), which is glibc-specific so also isn't present in other libc implementations such as musl. Instead of detecting whether we are building for Apple or not, just probe the to see if we have dlvsym.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 9632c7a..ceac94f 100644
--- a/meson.build
+++ b/meson.build
@@ -81,15 +81,12 @@ endif
# The remaining platform specific API for GL/GLES are enabled
# depending on the platform we're building for
if host_system == 'windows'
- build_apple = false
build_wgl = true
has_znow = true
elif host_system == 'darwin'
- build_apple = true
build_wgl = false
has_znow = false
else
- build_apple = false
build_wgl = false
has_znow = true
endif