summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2018-02-24 14:01:46 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2018-02-24 14:01:46 +0000
commit1489c20770f882e2cf778190269d4abab5cc018e (patch)
tree01d1842927c21a0eb0767aa415ef2e9c36969d23 /meson.build
parent60bb7672c10494aa6521ba3a157989cccc3490a2 (diff)
downloadlibepoxy-1489c20770f882e2cf778190269d4abab5cc018e.tar.gz
meson: Use get_supported_arguments()
Instead of iterating over the list of compiler flags, we should use the get_supported_arguments() method of the compiler object, which does it for us — and maybe, in the future, will be optimised to do the checks in parallel.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 9281ea5..9a09238 100644
--- a/meson.build
+++ b/meson.build
@@ -159,12 +159,7 @@ else
test_cflags = []
endif
-common_cflags = []
-foreach cflag: test_cflags
- if cc.has_argument(cflag)
- common_cflags += cflag
- endif
-endforeach
+common_cflags = cc.get_supported_arguments(test_cflags)
libtype = get_option('default_library')